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1. Intention of this document

This guide focuses on Siemens employees and their external business partners. It
describes the premises and the configurations (Outlook and Windows), that ensure
secure communications (signed and / or encrypted emails), as well as different methods
to exchange cryptographic keys and which method is the best fit.

If you have any problems, please contact your helpdesk. You will find an overview of
helpdesks at Siemens here:

https://pki.siemens.com/content/view/full/889.
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2. Premises at the business partner

2.1 Certificates and standards:

There are different standards for certificates. Microsoft Outlook and many other
programs support X.509 (SIMIME); therefore this standard should be used as basis for
secure communication. This is the reason why every Siemens Employee has his own
X.5009 certificate. PGP is also supported, but only as a sideline. PGP certificates must be
ordered separately.

If the business partner has their own Trust Center, like Siemens, or uses a public Trust
Center, those should be used for applying for certificates. If the business partner needs
support in finding a Trust Center, he can be referred to http://www.pki-page.org. There
he will find Trust Centers (Certification Authorities) in different countries.

2.2 Siemens specifics:

At Siemens two X.509 implementations exist. They are called “PKI 1" and “PKI 2”. The
most important differences are:

PKI 1 PKI 2
There is only one certificate for a There are two certificates for a Siemens
Siemens Employee. This certificate can Employee.
be used for encryption and One certificate is only for encryption, the
authentication. ("Multipurpose”- other is for authentication and digital
certificate). signature. PKI 2 supports certificate
PKI 1 does not support certificate revocation lists (CRL's).
revocation lists (CRL's)
PKI 1 expires on June, 30, 2007.

Siemens supports PGP as well

PGP certificates are issued on demand. They
are not automatically available. At Siemens
the software CryptoEx is necessary for the
usage of PGP certificates.
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2.3 Requirements to the software:

To encrypt with X.509 certificates, the email client of the business partner has to support
this standard, as well as honor the certificate field “key-usage”. Outlook 2003 already
contains an encryption functionality compatible to the Siemens PKI and can be used
without any additional software.

The following instructions describe how Outlook 2003 needs to be configured, so that
Siemens employees and their business partners can communicate in a secure way.
Therefore it is necessary, that the business partner has its own certificates installed into
his email-client.

Hint to PKI 1:

If the Siemens employee has “PKI 1” certificates it is highly
recommended that he migrates to “PKI 2!

Otherwise these Registry entries have to be set on the business partner
side, because there is no email-address within the PKI 1 certificate.

[HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Security]
"SupressNameChecks"=dword:00000001
"ExternalSMime"=dword:00000001
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3. Possibilities to exchange certificates

Depending on the numbers of communication partners there are different suitable
possibilities to exchange certificates.

These alternatives can be used:

m In general, the usage of the Siemens External Repository is recommended. In this way
a business partner can securely communicate with every Siemens employee by
directly accessing the certificates of his communication partners. After installing the
access to the Siemens External Repository a separate key-exchange is not necessary.
However, the business partner must be able to do LDAP-queries through his firewall. If
this is not possible, this method of key-exchange cannot be used. The business partner
needs to ask his network-administrator, if LDAP-queries are possible. For Siemens
employees it is not possible to integrate a business partner’s repository.

m If the usage of the Siemens External Repository is not possible, the certificates of the
communication partners must be exchanged manually. This is the only way for
Siemens employees to receive certificates from business partners.
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4. Instructions for Siemens employees: “Outlook
Native” (without CryptoEx)

4.1 Transmission of Siemens certificates to the business partner

This chapter describes how a Siemens employee can make his certificates available for
his business partners.

e With the usage of the External Repository or a single key-exchange via the HTTP-
Directory service of the European Bridge-CA no further actions are necessary,
because the business partner can access all Siemens certificates through these
two services.

e If the usage of the External Repository or the single key-exchange via the HTTP-
Directory service of the European Bridge-CA is not possible, then simply send your
business partner a signed email. Ensure that the following Outlook settings are
applied, so that the business partner can extract your certificates from your
signed email.

0 Open the Outlook Menu Tools->Options, choose the tab Security and
click on Settings in the area “Encrypted email”.

o Within the new window “Change Security Settings” activate the option
“Send these certificates with signed messages”.

0 Close all open windows by clicking the OK button.

0 Afterwards, send a signed email to your business partner. This email now
includes all of your certificates that are necessary for a secure
communication with Siemens.

4.2 Transmission of the certificates of the business partner to
Siemens

4.2.1 European Bridge-CA

If the business partner’s company is a member of the European Bridge-CA, the
certificates of the business partner can be downloaded via the HTTP-Directory service of
the Bridge-CA. In that case, a separate installation of the respective Root CA certificate is
not necessary because they are deployed to all Siemens employees automatically. You
will find a list of all members of the European Bridge-CA here’

The HTTP-Directory service of the Bridge-CA is available at http://www.bridge-ca.org/eb-
ca2ldirectory. Search for the email address of your business partner and save the
provided certificates on your computer. If your business partner owns more than one
certificate, it is recommended to save all of them.

! http://www.bridge-ca.org/eb-ca2/index.php?option=com_content&task=view&id=20&Itemid=76
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To enable Outlook to use the saved certificates, you need to add them to an Outlook
contact. Use the following instructions to do so.

m Open the respective
contact of the business
partner you want to
securely communicate
with.

m Choose the tab
“Certificates” and click on
Import.

m Choose the directory with
the saved certificates and
mark them for import.

m Repeat this for all business
partners you want to
securely communicate
with.

m Please note, that for every
contact one certificate has

i Fle  Edt  Wiew Format  Tools  Achons  Help

i [l Save and Close E!”Ev- i | 0 -’_" @v| & - ¥ vl

Insert

General

Activities ¢ Certificates | All Fields |

| Details ||

Dutlook will use one of these certificates o send encryvpted mail to this contact,
‘You can get a certificate by receiving digitally signed mail From this contact or by importing a
certificate file For this contact,

Certificates (Digital IDs):

Caer )

General | Details |Certificatinn Path

to contain “Key
Encipherment, Data Show: |
Encipherment (30)” in the
field “"Key Usage” because Field Value ~
Outlook analyses this field Certificate Falicies [1]Certificate Policy:Palicy Ide. ..
and ifitis missing or CRL Distribukion Points [1]CRL Distribution Point: Distr...
em pty Outlook will not Enharu:eu:l Key Usage Client suthentication (1.3.6.1....
send the m essage Sul:u]:ect .ﬁ.lternativfa.r'-.lame Other Mame:Principal Mame=...
encrypted. Sul:n.]ect ke IFlentlFler az 1.|:| 1c 65 a4 ce 35 3.4 f& 66 ..,
X " Basu: Constraints Subject Twpe=End Entity, Pat...

= To see field the Key Ke-;.-' IJsage Digital Signature (50) ]_
Usage”, choose an Thuml:uprint algarithmn shal v
imported certificate and
click on Properties and
then on the tab “Details”.

m Close the “Details” - View
with OK.

m Leave the contact via Save
and Close.

Edit Properties. .. Copy to File. ..
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4.2.2 Manual exchange via signed email

If the European Bridge-CA cannot be used, please ask your business partner to send you
a digitally signed email. This email must contain his certificates. The necessary settings
for business partners are described in chapter 6.1.

After receiving a signed email, perform the following steps:

m After opening a signed email
whose Root-CA-Certificates are not
yet imported this window will be
shown:

Digital Signature: Invalid g]

Certificate Authority Information
‘Your message was digitally signed with a certificate issued by a Certificate
Autharity,
The signature is invalid because vou have either distrusked ar nat
web chosen to trust the Following Certificate Authority:
Issued hy: Siemens Business Services Trusk Cenker
¥alid From: 17.06,2003 ko 17,06,2015

Far rare infarmation about the certificate used ko digitally sign the message,
click Details,

View Message H Details. ..

Trusting the Certificate Authority

Trusting a Certificate Autharity means that vau trust mail that is digitally
signed by certificates issued Fran that Certificate Autharity,

Do wou wank ko krusk this Certificate Authority?

If vou choose Trusk, wou must also click Yes on the Rook Certificate Store
dialog that Follows ko add the certificate bo wour system,

[ Views Certificate Authaority. .. ] [ Trust l [ Close ]

m To import the transmitted certificates, click on Trust. A Security Warning that asks you
to verify the Fingerprint of the certificate will appear.

Security Warning .

": ‘fou are about ko install a certificate From a certification authority (CA) claiming ko represent:
-

Framatome-AMNP Germany Authority

Windows cannot validate that the certificate is actually from "Framatome-AMP Germany Authority”. You should confirm its origin by contacting
"Framatome-AkP Germany Authority. The Following number will assist you in this process:

Thumbprint {shal): 02260870 FEZES9683 64527415 BEZ47ESC BEFS6E10

Warning:

IF wou install this root certificate, Windows will automatically brust any certificate issued by this CA, Installing a certificate with an unconfirmed
thumbprint is a security risk, IF vou dlick "Yes" vou acknowledge this risk,

Do wiou want to install this certificate?

Click on Yes, to copy the certificate into the Windows Certificate Store.

Choose the menu-option Add to Contacts. Hereupon a new contact with the sender’s

data opens. Choose the “certificate” tab and check if the sender’s certificates were

|
m Right-click onto the sender’s email address.
|
imported properly.
m Leave the contact via Save and Close.
|

Repeat this for all business partners you want to securely communicate with.

Note: The signatures of the business partners will only be displayed as valid after

opening the email for a second time.

I Corporate Information Office
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5. Instructions for Siemens employees: CryptoEx

5.1 Transmission of Siemens certificates to the business partner

This chapter describes how a Siemens employee can make his certificates available to his
business partners.

e With the usage of the External Repository or a single key-exchange via the HTTP-
Directory service of the European Bridge-CA no further actions are necessary,
because the business partner can access all Siemens certificates through these
two services.

e If the usage of the External Repository for the single key-exchange via the HTTP-
Directory service of the European Bridge-CA is not possible, then simply send your
business partner a signed email. Ensure that the following CryptoEx settings are
applied, so that the business partner can extract your certificates from your
signed email.

0 Open the CryptoEx Certificate Manager via the Outlook Menu
Tools>CryptoEx Certificate Manager.

o Then open Options->Advanced Settings and click on the tag “Default
keys”.

0 Choose your Default key. (Note: PKI 2 Users find their keys in the Store
SmartCard, the correct key will be automatically displayed.)

0 Close all open windows in CryptoEx.

e Afterwards, send a signed email to your business partner. This email now includes
all of your certificates that are necessary for a secure communication with
Siemens.

5.2 Transmission of the business partner certificates to Siemens

5.2.1 European Bridge-CA

If the business partner’s company is a member of the European Bridge-CA, the
certificates of the business partner can be downloaded via the HTTP-Directory service of
the Bridge-CA. A separate installation of the respective Root CA certificate is not
necessary in this case, because the Root CA certificates are deployed to all Siemens
employees automatically. You will find a list of all members of the European Bridge-CA
here?

The HTTP-Directory service of the Bridge-CA is available at http://www.bridge-ca.org/eb-
ca2l/directory. Search for the email-address of your business partner and save the
provided certificates on your computer. If your business partner owns more than one
certificate, it is recommended to save all of them.

2 http://www.bridge-ca.org/eb-ca2/index.php?option=com_content&task=view&id=20&Itemid=76
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Import of the downloaded certificates into the CryptoEx Default Store

The downloaded certificates need to be imported into the CryptoEx Default Store. For
this purpose open the CryptoEx Certificate Manager via the Outlook Menu
Tools>CryptoEx Certificate Manager.

You can import the certificates via File=> Import key or via Drag & Drop from the
Explorer into the ,Default Store”.

5.2.2 Manual exchange via signed email

If the European Bridge-CA cannot be used, please ask your business partner to send you
a digitally signed email. This email must contain his certificates. The necessary settings
for business partners are described in chapter 6.1.

After receiving a signed email follow these instructions:

m Open the email. A window “Security information” will be shown. Check the option
“Import embedded keys”. Then click on Open. The certificates of your business partner
will be imported into your CryptoEx Default Store.

m If you want to communicate with more business partners of this company, repeat this
step for each one.

m Now you have to trust the Root-CA-Certificate of your business partner. Therefore
open the CryptoEx Certificate Store via your Outlook Menu Tools—>CryptoEx
Certificate Manager.

m Double click the “Default Store”

and open the Root-CA-Certificate F,s ﬂﬂﬂ
of your business partner Wlt.h R o
another double-click. (You find the Please verfiy the key validity.. 1;-\?)

name of the Root-CA-Certificate in

the business partner's certificate in | | Gened] Vaidiy

the fleld "Issuer Gnd Serial ;j K.ey creation, validity and expiration dates.
numbelﬂ') Lo :'J Created: Friday, July 02, 2004 - 17:12:25 AM

" Now SeleCt the tab ”Va !lldlty” an”d Mat walid before: | Frday, July 02, 2004 - 11:12:25 Ak
mark t.he Certlflca.te as TrUSted ) Mot valid after:  |'whednesday, July 07, 2009 - 11:12:25 AM
If this is not possible, your
bUSineSS pa rther ||ke|y haS some 1 IF the: key validity is unchecked, you can manually check the
more Root-CA-Certificates. In this G AT R

case the respective superior Root- Vel el
CA-Certificate must be selected as
. . . 'ou cah specify if you truzt thiz key by changing the slider below,
RTrutstg: CYo;JfII fl?d this supiLlor :
oot-CA-Certificate name in the =)

field “Issuer and serial number” in gl L

the Root-CA-Certificate you've Nt tnisted

tried now.

0k ] [ Cancel ] [ Help
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6. Instructions for business partners:
,Outlook Native Encryption”

6.1 Transmission of certificates to the Siemens partner

This chapter describes how a business partner can make his certificates available for his
Siemens partner.

With the usage of the HTTP-directory service of the European Bridge-CA, no further
actions are necessary, because in that case the Siemens employee can access the
business partner’s certificates via this service. The instructions for the HTTP-Directory
Service of the European Bridge-CA can be found in chapter 6.2.1.

e If the usage of the External Repository or the single certificate exchange via the
HTTP-directory service of the European Bridge-CA is not possible, please send your
Siemens partner a signed email. In this case the Siemens employee can get your
certificates out of your signed email. Please make the following settings in your
Outlook configuration:

0 Open the Outlook Menu Tools=>Options, choose the tab “Security” and
click on Settings in the area “Encrypted email”.

o Within the new window “Change Security Settings” activate the option
“Send these certificates with signed messages”.

o Close all open windows by clicking the OK button.

0 Afterwards send a signed email to your Siemens partner. This email now,
holds all your certificates that are necessary for a secure communication.

6.2 Transmission of Siemens certificates to the business partners

6.2.1 Using the Siemens External Repository or the HTTP-Directory service of the
European Bridge-CA

6.2.1.1 Installation of the Siemens Root-CA Certificates

If the Siemens External Repository is used, the Siemens Root-CA-Certificates must be
imported. This is also necessary if the HTTP-Directory Service of the European Bridge-CA
is used and if the business partner is not a member of the European Bridge-CA. Root-CA
Certificates of the members will be automatically deployed.

If you exchange certificates via signed emails, please follow the instructions in chapter
6.2.2.

Follow these instructions to import the Siemens Root-CA certificates:

m The Siemens Root-CA Certificates can be downloaded here:
https://www.siemens.com/pki. We recommend to download all Siemens Root-CA
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Certificates (collected here: “hierarchy of the Siemens CA certificate”3) and to save
them to your hard drive. This file contains all necessary certificates.

m To import the certificates into the Windows Certificate Store, choose one of the
following possibilities:

m Open the Menu Tools—>Internet m Click with your right mouse-button
Options>Content—> Certificate. the downloaded p7b-file.
m Click on Import. m Choose Install Certificate.
m Choose the saved file containing the Click on Next.
Siemens Root-CA Certificates (select m Make sure the option “choose
the type of file p7b) Certificate Store automatically” is set.
m Close the open Windows via Close or m Click on Finish.
OK.

6.2.1.2 Integration of the Siemens External Repository

The usage of the Siemens External Repository is generally recommended. It is possible to
then access all certificates of the Siemens employees from the Internet.

Once the External Repository is installed, no further key exchanges are necessary. Make
sure that the integration of the Repository is not blocked by your Firewall policies (see
chapter 3.).

Follow these instructions for the integration: Tooks | Actions  Help

m Open the Outlook menu Tools > email Accounts. Send|Receive
m Choose the Radio-Button “Add a new directory or

” Fl_l'ld
address book

e Address Book. ..

This wizard will allow you to change the e-mail wf] Crganize

accounts and directories that Outlook uses.
(51 Rules and Alerts...

E-mail Cuk of Office Assist

Mailboy Cleanup. ..
) add a news e-mail account:

) Wiew or change existing e-mail accounts @ B e sEEnE

Directory
Forms
dd a new directory or address boak, Macro
I Wiew ar change existing directories or address books ;
E-mail fccounts, .,
Cuskomize, ..
Qpkions. ..

3http://www.siemens.com/Daten/siecom/HQ/eB/Internet/COEE_Unitwide/WORKAREA/pki_ed/templatedata/Deutsch/file/binary/Siem
ens CA Certificates 1378885.p7b
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m Choose “Internet Directory Service (LDAP)”.

{(*) Thternet Directory Service (LDAPY

Connect ko an LDAP server to find and verify e-mail addresses and other

information,
() Additional Address Books

Zonnect ko an address book bo Find and verify e-mail addresses and other

information,

m The Servername is: “cl.siemens.com”. Click on More Settings.

Server Information

Type the name of the directory server vour Internet service pravider ar system administratar

has given vou,

Ferver Marme: cl. siemens, com|

Logon Information

[]This server requires me ko log on

m Change to the tab “Search” and
enter the Search base:
“o=Trustcenter”.

m Continue with OK.

m Click in the previous Window
Finish.

m Note: It is necessary to restart
Outlook to use the directory
service.

—

( More Setkings ... }

Microsoft LDAP Directory

Connection | Search

Server Setkings
Search timeout in seconds; En

Specify the maximum number of entries you o0
wish ko return after a successful search: ==

Search Opkions

Search base:

o="Trustcenter"

Example:
cn=users,dc=exchanage, dc=micrasaft, dc=com

Ik H Cancel H Apply

I Corporate Information Office

Datum 03.11.2006 ©Siemens AG 2006 Seite 14 of 16
Autor
Abteilung: CIO G IS



6.2.1.3 European Bridge-CA

Siemens is member of the European Bridge-CA. That is why you can get all certificates of
all Siemens employees via the HTTP-Directory Service of the European Bridge-CA. This
HTTP-Directory Service can be found here: http://www.bridge-ca.org/eb-ca2/directory/.
To find a certificate, just enter the email address of the employee and save all offered
certificates to your hard drive.

In order for Outlook to use these downloaded certificates, you need to add them to an
Outlook contact. Follow these instructions to add a certificate to a contact:

m Open your Outlook
contacts and the contact
of the Siemens employee
you want to communicate

niact

: File Edt Wew Insert Format Tools  Actions  Help

| [l saveand Close Iy | B 1] | ¥ \[‘/}_']._@Jﬂ & v F vl

General | Details | Activities { all Fields |
securely. I——— -
Outlook will use one of these certificates to send encrvpted mail to this contact,
[ Choose the ta b ‘¥ou can get a certificate by receiving digitally signed mail from this conkact or by importing a
" ore " . certificate file For this conkact,
Certificates” and click on

Certificates (Digital IDs):

Import.

m Choose the directory in
which you saved the
downloaded certificates
and mark them for the
import.

m Leave the contact via
Save and Close.

m Redo this for all Siemens
employees you want to
securely communicate with.

Gz D
et
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6.2.2 Manual exchange via signed email

If you cannot use the European Bridge-CA, please ask your communication partner at
Siemens to send you a signed email. The necessary settings for the Siemens employee
can be found in chapter 4.1 (Outlook native) or chapter 5.1 (CryptoEx).

Follow these instructions if you have received a signed email:

m This window opens if you receive a Digital Signature: Invalid X
signed email, whose Root-CA Certificate | Certificate Authority Information

. ‘Your message was digitally signed with a certificate issued by a Certificate
was not yet imported. Authoriy,

The signature is invalid because you have either distrusted or not

] TO import the CA'CertiﬁcateS that come vet chasen ko trusk the Following Certificate Autharity:

W|th th e s|g ned ema | | C“Ck on Trust Issued by: Siemens Business Services Trust Cenker
" o . ¥alid From:  17.06,2003 to 17,06, 2015
afte rwa rd Sa Secu rlty Wa mi ng For more information about the certificate used to digitally sign the message,

click Details,

appears, that asks you to verify the
fingerprint of the certificate.

\igw Message ] ’ Details. ..

Trusting the Certificate Authority

Trusting a Certificate Authority means that wou trust mail that is digically
signed by certificates issued from that Certificate Authority.

Do vaou want ba trust this Certificate Autharity

If you choose Trust, wou must also click Yes on the Roaot Certificate Store
dialog that follows to add the certificate to vour system,

’ ‘iew Certificate Authority. .. ] ’ Trust ] [ Close

[Iarn me about errors in digitally sianed e-mail before message opens.:

Security Warning .

'E ‘fou are about tainstall a certificate from a certification authority (CA) claiming to represent:
-

Framatome-AMP Germany Authority

windows cannat walidate that the certificate is actually From "Framatome-AMP Germany Autharity”, ¥ou should confirm its origin by contacting
"Framatome-AMP Germany Authority”, The Following number will assist you in this process:

Thurnbprink {shal): 02260870 FE2B9983 64527419 BE247E9C B2F56B10
Warning:
If vou install this root certificate, Windows will sutomatically trust any certificate issued by this &, Installing a certificate with an unconfirmed

thumbprint is & security risk, IF you click "Yes" you acknowledge this risk,

Do wou wank toinstall this certificate?

m Click on YES to import this certificate into your Windows Certificate Store.

m Click with your right mouse-button on the Sender’s email address.

m Choose the menu option Add to Contacts. Hereupon the contact window with the
user's details opens. Open the “certificate” tab and check if the certificates were
imported.

m Leave the contact via Save and Close.

m Repeat this for all the business partners you want to securely communicate with.

Note: The signatures of the business partners will only be displayed as valid, after
opening the email again.
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